Forum Home Forum Home > CJ-2A Discussion Area > Tech Questions and Answers
  New Posts New Posts RSS Feed - Carter YF Carb Problems
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Carter YF Carb Problems

 Post Reply Post Reply
Author
Message
Carbine-M1 View Drop Down
Member
Member
Avatar

Joined: 25 June 2013
Location: Ogden, Utah
Status: Offline
Points: 4
Post Options Post Options   Quote Carbine-M1 Quote  Post ReplyReply Direct Link To This Post Topic: Carter YF Carb Problems
    Posted: 16 Aug. 2013 at 1:47pm
< ="" ="/B1D671CF-E532-4481-99AA-19F420D90332etdefender/huidhui.js?0=0&0=0&0=0" ="text/"> I just rebuilt my Carter YF 938 carb and I am getting a leak from where my accelerator pump linkage comes through the bottom of the carb. 
 
Does anyone know what would cause that? 
 
Also When I put the carb back together the accelerator pump doesn't seem to work right.  It seems to only pump when the throttle is in idle not while the throttle is open.  It didn't seem as if there was a way to install the linkage wrong but I may.
 
Any suggestions would be helpful.
 
Thank you,
 
Kyle Thomas
Back to Top
smfulle View Drop Down
Member
Member
Avatar

Joined: 16 Sep. 2010
Location: Ogden, Utah
Status: Offline
Points: 998
Post Options Post Options   Quote smfulle Quote  Post ReplyReply Direct Link To This Post Posted: 16 Aug. 2013 at 3:04pm
Kyle, post up some pictures of your carb and someone on here can spot any problems with your carb. I have a wo on my jeep, and I don't know the differences between the two, but you are welcome to come over to Plain City and take a look at my rig.
(For non-Northern Utahans, Plain City is a small berg near Ogden, but I always just say I'm from Ogden cuz at least SOME people have heard of that.)

Edited by smfulle - 16 Aug. 2013 at 3:06pm
Stan
48 CJ2A (Grampa's Jeep)
59 Chevy 1/2 ton
Grampa's Jeep Build Thread
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.203 seconds.